SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Wireless > RT-AC66U  
  Forum  
  Topic : [Problem]Very slow 5ghz wifi speed New Topic
Jess
Member
Posts : 3
Level :
Tech Points : 1
From: United States
Posted:5/29/2017 11:03:00 AM # 1
Hey all>
>I'd like to ask for any help I can get with a problem I've been struggling with for a long time now.>
>Despite everything Ive tried, the performance of my 5ghz wireless (the only one I use) is terrible.>
>I have a 200Mb connection from Comcast, and if I connect my laptop to the router with a cable it consistently tests at 200Mb/s.>
>However, the same laptop, connected to the 5ghz WiFi, sat 3 feet from the router, consistently tests at 20Mb/s. It's not just theoretical numbers either... everything is sluggish, and streaming buffers. Downloads are very VERY slow.>
>I realise there's speed drop off on WiFi, and I realise that congested channels is a huge problem. I do live in an apartment complex, and there are a lot of other signals, but there isn't another 5ghz WiFi on the same channel as me. I feel like non of this is enough reason for the performance I'm getting.>
>Everything is locked down, I'm on firmware 3.0.0.4.380_7378, and I'm running on channel 161 @ 80MHz.>
>I don't know. I'm sure there are some settings I could set to affect this, but I don't know if there's a silver bullet out there to explain why this is happening. I find it hard to believe that this is just what I have to put up with - even in a busy apartment complex.>
>I'm pretty desperate here. I can't watch a movie, because it buffers every 90 seconds. Downloading things is painful, and even browsing the web is sluggish and not particularly responsive.>
Any help or advice very much appreciated. If anyone wants to help and needs information, please ask... I'll be as responsive as I can be.>
>Many many thanks in advance.>Jess

  Reply Reply Quote & Reply Quote & Reply
UK Sentinel
Member
Posts : 963
Level :
Tech Points : 421
From: GBR
Posted:5/29/2017 12:52:00 PM # 2
I agree 20Mbps does sound low, can I ask what laptop you are using, is it windows 10 and what is the wifi card upon it?


UK Sentinel

  Reply Reply Quote & Reply Quote & Reply
Jess
Member
Posts : 3
Level :
Tech Points : 1
From: United States
Posted:5/30/2017 1:24:00 AM # 3
Hey. Thanks for responding. I have a 2016 MacBook Pro. It's a 15" one, and I've only had it a couple of months. I haven't really done speed tests on any networks other than my own, but I didn't anticipate that it was the problem. Worth saying, that I should have mentioned before, my laptop isn't the only wifi device that I use. I have a FireTV stick, an iPad, cell phones and my wife has a laptop. All suffer the same issues. Thanks again. Jess

  Reply Reply Quote & Reply Quote & Reply
UK Sentinel
Member
Posts : 963
Level :
Tech Points : 421
From: GBR
Posted:5/30/2017 3:17:00 AM # 4
>No problem, Routers, such fun!!!!!!!!!!!!!

So the iPAD is also reporting slow 5GHz wifi speeds?


If wife's laptop is also showing very low speeds then defo Router issue


Try disabling QoS (if enabled) and see if this helps?

Also ensure router is not near wireless telephone, microwaves and door bells (wireless) etc.

If you connect wifi clients to 2.4GHz does this improve speeds?

If above does not help, try under Advance Settings > Wireless > General, Wireless mode to Auto, Channel Bandwidth to 40 MHz and Control Channel to 46 and give router reboot and see if this helps?

FYI - (80MHz) can be problematic for Channel Bandwidth,

Same Tab is the Professional option, and we can run through options there if the above does not increase speeds?

UK Sentinel

  Reply Reply Quote & Reply Quote & Reply
Optimus2357
Member
Posts : 61
Level :
Tech Points : 59
From: USA
Posted:5/30/2017 4:35:00 AM # 5
Could you copy paste all your settings as shown in this emulator? Please also include Advanced Settings > Wireless > General > Frequency 5Ghz too. Or if easier, post a screenshot.>
>Also, do you have any Windows devices? The number of iOS and OSX wireless tools is limited. There is a built in utility, but IMO it isn't very detailed. See link for instructions, or if you have Windows, try this program. Either way, post a screenshot of the 5Ghz networks around you. The windows program may find networks that hide their SSID that you  might not otherwise see. 

  Reply Reply Quote & Reply Quote & Reply
Jess
Member
Posts : 3
Level :
Tech Points : 1
From: United States
Posted:5/30/2017 10:42:00 AM # 6

Quote:
Author: Optimus2357 Posted: 5/30/2017 4:35:00 AM

Could you copy paste all your settings as shown in this emulator? Please also include Advanced Settings > Wireless > General > Frequency 5Ghz too. Or if easier, post a screenshot.>
>Also, do you have any Windows devices? The number of iOS and OSX wireless tools is limited. There is a built in utility, but IMO it isn't very detailed. See link for instructions, or if you have Windows, try this program. Either way, post a screenshot of the 5Ghz networks around you. The windows program may find networks that hide their SSID that you  might not otherwise see. 

Hey all>
>OK so following on for all your advice and thoughts I started specifically testing all the devices in my house. I realised I had anecdotally noticed a lack of perdformance around my devices, but had only been running a speed test on my MacBook.>
>It turns out that every device in my house was testing at somewhere between 120Mbps, and 160Mbps. Only my MacBook was reporting slow.>
>I have Parallels with Windows on my MacBook, and even that tested at 150Mbps.>
>So I went looking in to why my MacBook might be slow, when everything else is fast, and I found this information, which I applied, and now I am testing on my MacBook at 150-170Mbps.>
>

After doing some research, I found a solution to the slowness of my Wi-Fi. If this happens to you in macOS Sierra, try the following.

class="code-block code-block-1" style="box-sizing: border-box; color: rgb(20, 20, 20); font-family: -apple-system, system-ui, "Segoe UI", Roboto, Oxygen-Sans, Ubuntu, Cantarell, "Helvetica Neue", sans-serif; font-size: 18px; background-color: rgb(255, 255, 255); margin: 8px auto; text-align: center;">
  1. Turn off your Wi-Fi completely
  2. Create a new folder on your desktop and name it
  3. Open your Finder (the smiley face icon on the dock) and press Command + Shift + G. All three keys at the same time
  4. This will pull up Go To Folder. From there type in: /Library/Preferences/SystemConfiguration/
  5. Look for the following files: com.apple.airport.preferences.plist, com.apple.network.identification.plist, com.apple.wifi.message-tracer.plist, NetworkInterfaces.plist, preferences.plist
  6. Copy and paste them to the folder you created in Step 2
  7. Then delete those .plist from the SystemConfiguration

One more step before you’re done. Restart your Mac computer. Once it’s rebooted, connect to your Wi-Fi again.

>
>So, I think I'm all good. I did apply all your settings to my router, but honestly I think my laptop was just an anomaly. I'm going to keep an eye on performance, and keep testing, and hopefully I'm all set.>
>Thanks everyone for your help and time.>Jess

  Reply Reply Quote & Reply Quote & Reply
UK Sentinel
Member
Posts : 963
Level :
Tech Points : 421
From: GBR
Posted:5/31/2017 2:49:00 AM # 7
Good to know the issue is primarily one device rather than the router unit itself.


Enjoy the new found Mac Wifi Speed ;-)


UK Sentinel

  Reply Reply Quote & Reply Quote & Reply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.