SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Audio Cards > Xonar U7  
  Forum  
  Topic : [Problem]Volume control dial doesn't work New Topic
danila99
Posts : 1
Level :
Tech Points : 1
From: United States
Posted:7/31/2013 8:32:00 AM # 1
Hi, I've just got my new Xonar U7 card.

When I turn (rotate) volume control dial nothing happens. I tried it in Headphone and Speaker modes — no effect. I need to adjust volume through windows controls.  I use latest Windows 8 64bit drivers I got from the support site for this card.

Is there anything I can do to resolve this?

Thanks.

  Reply Reply Quote & Reply Quote & Reply
Lloyd
VIP Member
Posts : 2
Level :
Tech Points : 1
From: South Africa
Posted:1/17/2014 9:26:00 PM # 2
I have the exact same problem, the tech support told me nothing, thanked me for "understanding" and then asked me send the device to a repair centre.

@danila99 If you have managed to overcome this problem, please post how you managed it. Ta.

PS Thanks ASUS for the automatic hearts at the bottom of this post.

  Reply Reply Quote & Reply Quote & Reply
Lloyd
VIP Member
Posts : 2
Level :
Tech Points : 1
From: South Africa
Posted:1/22/2014 7:00:00 AM # 3
[FIXED][On my PC at least]

I took the liberty of coding my own solution to this problem. I've become rather irritated after learning that the hardware is operating fine - some firmware to send an HID command for volume would be fantastic though... thanks for that ASUS.

So, first thing you gotta do is download the libusbk library from:
http://sourceforge.net/projects/libusbk/

Then, you gotta install the downloaded file with a filter driver on the HID device of Xonar U7... you'll note that there are three entries for the Xonar: the composite parent, the audio device and the HID device. Cool.

Now, download my code and executable from:
http://www.megafileupload.com/en/file/491464/U7VolumeControl-rar.html

Extract this stuff to "C:\". Inside is the code I wrote/collaged, an executable and an xml file to be imported into the task scheduler.

Try just executing the .exe and all should work. To automate the process, import the .xml file into Control Panel->Administrative Tools->Task Scheduler or create your own task to open the exe on workstation unlock, making sure that each new instance kills the one before (there's a setting at the bottom of one of the tabs to the right)

NB. If you change the USB port of the U7, you gotta reinstall the filter driver.

The app should search for the device with the correct VID and PID and the volume control done using COM so I can't see why this wouldn't work on another PC. Holding thumbs :)

  Reply Reply Quote & Reply Quote & Reply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: yoyolai New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.