SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Multimedia > O!Play HDP-R1  
  Forum  
  Topic : [Sharing]How to convert HD1, H2 and HD3 to AMP_R8 OS! New Topic
sasaurus
Member
Posts : 21
Level :
Tech Points : 47
From: Canada
Posted:2/24/2012 4:57:00 AM # 1
First you need to know your players bootcode. 17 and lower requires you to first upgrade. 18 or above is ok. To check your bootcode go to the homescreen and press stop then play on the remote.

If your bootcode is 17 you can upgrade to bootcode 23. (note: bootcode 23 is from a Pal unit and come with a PAL firmware, this may cause NTSC users to have trouble seeing there screen after the inital upgrade if your tv is not dual compatible)

To upgrade you download the install.img file from here:

Download HDP_R3_FW_121PAL_BOOTCODE_23.zip

Place it on a usb stick formatted in FAT32 (make sure it is the only file on the stick)

You install it by telnet using the "soft reset" method found here:

http://www.moservices.org/forum/viewtopic.php?f=12&t=88

To telnet by soft reset:
(if using Vista or Windows 7 you first need to enable telnet. Go to Control Panel/Programs and Features and click "Turn Windows Features On or Off" and check the box beside "telnet client")

1) Go to setup on Oplay and write down its IP address eg 192.168.0.102
2) Plug the usb stick with the bootcode upgrade or HD2 software into the Oplay.
3) On your pc run a command prompt (run/cmd) and type: telnet <oplay ip>
 example: telnet 192.168.0.102
4) next you will see either venus login or oplay15 login, type root
5) next copy/paste the memory clearing command line that is found in the above link and press enter (example below...)

echo "        " | dd of=/dev/mtdblock/0 bs=2048 seek=8192


6) next type reboot. The Oplay will now reboot and install the software. Be patient...do not panic...this process can take sometime, the Asus screen may hang. DO NOT unplug or turn off anything...Wait!!

If you have installed the bootcode upgrade, re-set up the network connection (oplays setup menu) and use the above telnet "soft re-set" method to install the AMP firmware. (note: after the upgrade you do not get a progress bar on your screen when the software installs, you will just see 1 blue light and 1 red light on the unit, the screen will stay black until it boots up).

You can also go back to Original Firmware using the same method.

Can't say how it works for PAL as I have NTSC.

AMP R8 firmware: http://www.moservices.org/files/amp_r8_pohd.zip

****Understand that you are messing with firmware here and there is a risk of "Bricking" your unit. If you try this, you do so at your own risk.*****

  Reply Reply Quote & Reply Quote & Reply
badkarma
VIP Member
Posts : 174
Level :
Tech Points : 191
From: GBR
Posted:2/25/2012 11:27:00 PM # 2
Thank you, I have tried this on one of my five O!Plays.

I had a PAL O!Play Bootcode 17, Firmware 1.35P

I did the first part all OK upgrading to bootcode 23.

Then I flashed the second part from your instructions and all OK but I must say I got the following (nice) messages, not just a black screen:

---------------------
"Preparing for update."

"It takes a few seconds."

(Red and blue LEDs on)
----------------------

... seconds elapsed ...

-------------------------
"Don't turn off the power!"

"Emergency upgrade Mode"

"Firmware: amp_r8_pohd"

(something else but was not quick enough to write down)
------------------------

... seconds elapsed ...

------------------------
"Update completed"
"System will reboot"
---------------------

... Asus screen for a few seconds ...

--------

... Blue screen for a few seconds ...

---------------

Play!on menu pops up!!!!!!!!!!!!!!!!!!!!!!!

Initial navigation all works OK

I will now configure my NAS scripts, run it a few days then report back :)

***YOUTUBE WORKS AND IS F-A-S-T!!!***

Thanks!

  Reply Reply Quote & Reply Quote & Reply
badkarma
VIP Member
Posts : 174
Level :
Tech Points : 191
From: GBR
Posted:2/26/2012 2:15:00 AM # 3
Quick update, although my telnet linux scripts power up the NAS and map shares as mounts under /tmp/ramfs/volumes, they do not show on the menus...

HOWEVER...

The shortcuts work better (and easier) than OPlay firmwares (even stay there on mains power off / on, not just standby :) ) so am using the shortcuts instead to trial. All look OK so far. :)

Some more cool features I have found including when playing videos, you can press [Musical Note] button, 'GOTO' then specify a HH:MM:SS to jump to in the video :)

  Reply Reply Quote & Reply Quote & Reply
badkarma
VIP Member
Posts : 174
Level :
Tech Points : 191
From: GBR
Posted:2/26/2012 4:49:00 AM # 4
Another update.

Problem.

After a while of playing media, the audio turns Dalek-ish. I find that if I switch off my Toshiba TV and then turn it back on (while OPlay(POHD8) is still playing) then audio is OK.

Googling Toshiba TVs with this issue it seems more of a Toshiba issue than a OPlay(POHD8) issue. Having said that I never had the issue with OPlay(1.29 through 1.40) so maybe the POHD8 'triggers the Toshiba issue.

Reading up on the Toshiba Dalek issue it only surfaces after a few hours of power on so I may be OK - I did have the TV on a long time yesterday when tinkering.

It my not really be an issue for me. I will see how it goes.

  Reply Reply Quote & Reply Quote & Reply
badkarma
VIP Member
Posts : 174
Level :
Tech Points : 191
From: GBR
Posted:4/11/2012 1:41:00 AM # 5
Well, after a few weeks of use I can report on the whole it is good.

Plus points are youtube and the Thumbnail pictures I have put on. Its all very nice.

Bad points are it seems to hand in the menus. Can be anywhere in menu system at any point in time. Averaging hangs once every two or three days. Sometimes I can Telnet and reboot it, other times I have to power off / on. If the hanging can be resolved it would be ace.

  Reply Reply Quote & Reply Quote & Reply
oak
Posts : 1
Level :
Tech Points : 0
From: Canada
Posted:4/20/2012 8:30:00 AM # 6
Yeah, this installed no problem on both of my machines. Previous boot code was 13 and 14, no prob with the updates. However, nice looking interface, but what can I do with it? It has been awhile since i've been on these forums, and I have never had a problem with either of my machines, thought I would see if there was any new firmware, and I saw this and said hey, what the heck. I've been over to moservices to see what they had to say, and unfortunately my russian is a little rusty. For the past two days i've been trying to use the main interface to stream movies and such, with no luck. I have no problem using the file browser, and its great to see tv and movies come up with all the clip art and what not, but there has to be more to this machine. I have tried using the OPLAY moservices manager, but it really does not seem to do anything. I cannot get this to play mp3 playlists, but music out of the folder plays no problem. I have also headed over to the AC RYAN site, as it seems that what this skin is, but this looks nothing like what they have, so I am a little unclear as to the full power of this firmware on an HDP-R1/2. Please if you have any suggestions, let me know. I'm not giving up on this firmware as i like the interface, and finally being able to go on youtube and all the other internet features. And the ability to hook up the keyboard, well that is just cool. Thanks

  Reply Reply Quote & Reply Quote & Reply
stokvis
Member
Posts : 17
Level :
Tech Points : 3
From: BWA
Posted:5/2/2012 11:33:00 PM # 7
i also did the update. Fixed the audio out of sync issue on my 3D plasma. Thanks!

  Reply Reply Quote & Reply Quote & Reply
joepienl
Posts : 1
Level :
Tech Points : 0
From: Netherlands
Posted:5/27/2012 2:00:00 AM # 8
I performed the update; YouTube says: cannot play media files Using the filebrowser to watch and listen to media works; the normal way does not. I'll experiment a bit more and will keep ypu posted ! Thanks you all ! Oh by the way; is it possible to just surf the internet ?

  Reply Reply Quote & Reply Quote & Reply
Bazcor
Member
Posts : 4
Level :
Tech Points : 2
From: Chile
Posted:5/28/2012 10:59:00 AM # 9
Hi,

Sorry about my ignorance.. could you explain a little bit or tell where I can find information about this new firmware version? I would like to understand the differences from Asus firmware and AMP_R8.

Thanks in advance,

Bazcor

  Reply Reply Quote & Reply Quote & Reply
velvetfog
VIP Member
Posts : 19
Level :
Tech Points : 12
From: CAN
Posted:6/10/2012 5:28:00 AM # 10
The AMP_R8 software is explained here:
http://www.moservices.org/forum/viewtopic.php?f=12&t=1030

  Reply Reply Quote & Reply Quote & Reply
1 2  Next  Last
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.