SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > P6X58D-E  
  Forum  
  Topic : [Problem]sata 3 problems New Topic
rut
Member
Posts : 8
Level :
Tech Points : 5
From: United States
Posted:7/29/2011 9:15:00 PM # 1
I've had this system for a while and I've constantly had problems with the sata 3 ports. Sometimes it works and I can see my two hd, other times I have to reboot, go into bios (make no changes), exit and it works again.

I just purchased an OCZ 120G Vertex 3 SSDto use as a boot drive and can't get it to work on the sata 3 ports. I've read that the Marvell 9128 controller isn't the best but I would think It should at least recognize the drives.

Mobo is an Asus P6x58D-E

So this is what I've done.

1. Connected ssd to normal sata 2 ports. No hard drives connected. Booted up
and loaded windows 7 (64bit).

2. Load mb drivers from asus cd including Marvell controller.

3. Restarted and went into bios to set marvell port to AHCI mode.

4. Shut down and connected SSD to marvel sata 3 port.

5. Boot up, works fine.

6. Shut down and add hard drive to sata 2 port.

7 Boot up and system can't find ssd

8. Move ssd back to sata 2 port and all is well again.

Very frustrating. Does anyone know of a fix for this problem?

The very first time installing windows I had the ssd connected to the sata 3 port and at the disk format screen it asked for a driver. I couldn't find a file for marvell, just the exe to install the driver. This is when I moved back to the sata 2 port.

  Reply Reply Quote & Reply Quote & Reply
Asus P6x58D-E I7 3.06ghz GSKILL 6gig Ram PC1600 2-WD Black SATA 6gig Sapphire Radeon 6870 XFX 750W Power Supply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.