SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Notebook > G72GX  
  Forum  
  Topic : [Problem]Screen Flickering New Topic
Busby
Member
Posts : 3
Level :
Tech Points : 2
From: United States
Posted:4/24/2010 2:30:00 AM # 1

I am having issues with screen flickering.  At times, it will get to the point that the display goes black and comes back on several times in a matter of seconds.  Luckily, it has only been that severe 2x.  Most times it is an annoying flickering that just freaks my eyes out.  It can be temporarily resolved by turning the brightness all the way up.  It does not seem to matter if full screen, window or even if a game is running or not.  Seems to just happen randomly.  Anyone else having similar problems?

Suggestions please......

Thanks

  Reply Reply Quote & Reply Quote & Reply
Otero
VIP Member
Posts : 1
Level :
Tech Points : 1
From: United States
Posted:4/25/2010 4:24:00 PM # 2

I'm having the same problem too. It started a couple of days ago (happening right now). It is really annoying, and, as you said, it doesn't really matter what the computer is doing, it just happens...

  Reply Reply Quote & Reply Quote & Reply
Steve1A
VIP Member
Posts : 4
Level :
Tech Points : 3
From: United States
Posted:5/20/2010 9:52:00 PM # 3
After 6 months with my unit, I have been experiencing flickering also, but not to the point that my screen went black -- perhaps because I intervened first.

What seems to work is:  Lower the laptop lid to where it is almost shut -- enough to blank the screen. Then reopen it wide again. It seems I do not have the problem again for many hours (I have the PC on all day).

I think the problem may have something to do with the laptop screen switch, located within the hinge on the G72GX. I read about a similar problem on another ASUS laptop model where it was suggested they push the screen switch button located on the laptop surface near the hinge on their model -- which is not accessible on our G72GXs.

  Reply Reply Quote & Reply Quote & Reply
Kalanhi
VIP Member
Posts : 25
Level :
Tech Points : 41
From: United States
Posted:5/22/2010 9:30:00 AM # 4
Mine did the same thing.  I got a RMA when the screen went black and Asus replaced MB.
Got it back today but can't get wireless adapter to turn on????

  Reply Reply Quote & Reply Quote & Reply
dewdude
VIP Member
Posts : 53
Level :
Tech Points : 64
From: United States
Posted:5/23/2010 10:16:00 PM # 5
My Compaq had a very similar problem.

The Lid sensor on that is similar to the one on these Asus. They use a magnetic switch system that, while making for a streamlined look, can cause issues. I don't think this is as sensitive as the Compaq was because I could put a magnet on the LCD and it thought the lid was shut.

anyway, basically what it sounds like you guys were having were the signals from the lid sensors weren't getting read...either from a bad switch or controller. Replacing the motherboard is generally a fix all since it actually turns out the BIOS plays a role with this.

mine occasionally flickers from an inverter acting wonky...and i'm the only person with a high enough flicker-response that I can see it. it never goes out but sits there and I can see about a 20hz pulsing in the brightness.

Kalanhi: see my other post in your thread about your wifi problem.

  Reply Reply Quote & Reply Quote & Reply
Dennis
VIP Member
Posts : 1
Level :
Tech Points : 1
From: Philippines
Posted:5/31/2010 9:35:00 PM # 6
I have the same problem too. I already e-mailed Asus support regarding this matter. Hoping they have the solution.

  Reply Reply Quote & Reply Quote & Reply
Woods
VIP Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:6/20/2010 2:26:00 AM # 7
Add me to the list of people with this issue :-(

  Reply Reply Quote & Reply Quote & Reply
Steve1A
VIP Member
Posts : 4
Level :
Tech Points : 3
From: United States
Posted:7/20/2010 4:23:00 AM # 8
I seem to have solved the screen flickering problem, but not in a way that pleases me.

It seems that when I turn up the brightness to the maximum level using the Fn+F6 keyboard command, the flickering does not occur. (I have tried this for a full week.) The moment I lower the brightness several notches down with Fn+F5, the screen flickering will begin within a few hours. Dropping the level just 2 notches causes the flickering to re-occur.

However, I am not pleased with the super-brightness of the top setting. (I have the latest drivers, BIOS, and nVidia drivers.) I will try to contact ASUS support to see why I cannot take advantage of  the screen-brightness setting without flickering. I will let you know if I get a solution (in coherent English) from them.

  Reply Reply Quote & Reply Quote & Reply
Woods
VIP Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:7/24/2010 12:30:00 AM # 9
I can confirm this. I had changed my power settings to "Overclocking Mode" which by default turns the screen brightness to its maximum. I was floored when the screen flickering disappeared entirely. I have not had a single flicker in several days.

  Reply Reply Quote & Reply Quote & Reply
Taylor
VIP Member
Posts : 1
Level :
Tech Points : 1
From: United States
Posted:7/24/2010 8:36:00 AM # 10
I'm having the same problem. Very disconcerting.

  Reply Reply Quote & Reply Quote & Reply
1 2 3  Next  Last
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: MCZ New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.