SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Notebook > N50Vn  
  Forum  
  Topic : [Problem]Screen Flickering Problems New Topic
Ling
VIP Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:11/2/2009 2:51:00 AM # 1
Hey, here's a weird thing.

Sometimes, my computer would have the screen flicker at random times.  Usually, I'd have to alter the screen's angle (i.e. move the lid around a little) and the flickering would stop.  It doesn't matter what I am doing at the time.  It would happen when gaming, MS Office, watching videos (DVDs and youtube so far), start-up, idling, etc. 

I've had this laptop sent back and they said they replaced the LCD on the manifest.

Any advice?

(I've tried reinstalling using the recovery disks, sending it back to ASUS for repairs, installing Windows 7, using both the nVidia and the ASUS drivers on their respective websites.)

  Reply Reply Quote & Reply Quote & Reply
Kirst
VIP Member
Posts : 1
Level :
Tech Points : 1
From: United States
Posted:11/3/2009 2:39:00 AM # 2
I had screen flicker while using an external LCD monitor connected to the vga port...had to buy a 3 prong to 2 prong power cord adapter to clear up noise coming across the ground.

  Reply Reply Quote & Reply Quote & Reply
Almario
VIP Member
Posts : 8
Level :
Tech Points : 3
From: Colombia
Posted:11/10/2009 12:09:00 AM # 3

Hi, i'm afraid this could be a Nvidia video chip failure like the problems they presented last year with the 8xxx series, my n50vn is presenting those white noise probles sinse the very moment I turn it on brand new, geting worst by day. reading about this seems not even the tecnical service can repair that. read about lcd change, inverter change and the isue reapeares in a few weeks. I wonder if this could be a video card isue.... gforce 9650m gt faulity???...

hope not.

P.D: if the isue is present in the external monitor like you notes, this is not a video ribon trouble.

  Reply Reply Quote & Reply Quote & Reply
Ling
VIP Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:11/11/2009 7:32:00 AM # 4
I don't see any problem when I hook it up onto an external monitor (only tried VGA so far)

Is there any patch to compensate for this?  I'm on the move a lot so that's why I picked such a powerful laptop.

  Reply Reply Quote & Reply Quote & Reply
Snoop
Member
Posts : 24
Level :
Tech Points : 38
From: New Zealand
Posted:11/11/2009 8:58:00 AM # 5
Edit :

Removed because Asus finally responded to me. took them awhile but yeah. hope the matter gets sorted out. will keep you all posted.

  Reply Reply Quote & Reply Quote & Reply
Lipman
VIP Member
Posts : 1
Level :
Tech Points : 1
From: United States
Posted:12/19/2009 10:32:00 PM # 6
I have the exact same problem, changing screen angle normally helps but it happens regardless of App, power source etc.  Anyone got ant ideas?

Contacted Tech support, sent laptop off and got it back again (after removing all data etc.)

1 week later still has the same problem.  I will send it off again and hope for better results.

Update:  1 year 350 days after purchase returned notebook again under 2 yr warranty for last ditch effort to resolve problem .   Asus replaced LCD - success !!! :)

Like having a new laptop - doing a system restore once a year is not a bad thing either.

  Reply Reply Quote & Reply Quote & Reply
Klein
VIP Member
Posts : 10
Level :
Tech Points : 2
From: United States
Posted:12/20/2009 4:38:00 AM # 7
I just received my laptop back from asus after 3 trips to them with this same issue. This time they FINALLY replaced some hardware - the LCD screen to be exact. At this point I'm not seeing the problem any longer, but we'll see it it stays fixed. Keep on ASUS about this problem. It took me a lot of complaining and 4 repair trips  overall (1 to a local repair, 3 times to their repair facility in California and lots of phone calls).

Best of luck!

Scott

  Reply Reply Quote & Reply Quote & Reply
Klein
VIP Member
Posts : 10
Level :
Tech Points : 2
From: United States
Posted:3/3/2010 7:47:00 AM # 8
Well, the problem still wasn't fixed. I've sent it in yet again, but apparently it's still sitting in repair with no other status than that. (very helpful).

Anyway, I'll post again once I know more - for what it's worth to anyone following this thread.

  Reply Reply Quote & Reply Quote & Reply
Ashe
VIP Member
Posts : 5
Level :
Tech Points : 2
From: Netherlands
Posted:4/3/2010 12:24:00 AM # 9
I'm glad to read that I'm not alone in this. I'm going to look for solutions.
I'll keep you posted.


Thomas

  Reply Reply Quote & Reply Quote & Reply
Jezzey
Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:6/1/2010 9:01:00 AM # 10
please let me know if any has found a solution to this. My wifes n50vn has this problem and I am hesitant to send it to get repaired if there is no fix. This is her computer that she uses at her job so it can't have it rma'ed 4 times for 1 month at a time. Also, any clue on what the warranty period on this bad boy is? Im running on about 15 months.

  Reply Reply Quote & Reply Quote & Reply
1 2 3  Next  Last
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: MCZ New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.