SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum  
  Forum  
  Topic : [Problem]More wireless internet connection problems New Topic
jeffsiegel
VIP Member
Posts : 1
Level :
Tech Points : 0
From: United States
Posted:7/10/2008 2:32:00 AM # 1
I can't get a wireless connection, and I get the same error codes as everyone else who has posted here. I have tried all the solutions (except going into the / and /home directories, which don't appear to be the same on my 900 as on the machine mentioned in the post).

Does anyone else have any thoughts? Do I need to return the 900?

And, for what it's worth, the 900 won't read my multimedias card, either.

  Reply Reply Quote & Reply Quote & Reply
GH
VIP Member
Posts : 31
Level :
Tech Points : 0
From: Netherlands
Posted:7/14/2008 6:51:00 PM # 2
Hi Jeff,

I have been using Atheros chipsets for quite a while now, and never really had any issues whatsoever with them. ASUS made a good choice, as Atheros offers high quality and highly functional 802.11 chipsets for a reasonable price.

What happens in most cases is that the wireless implementation is kinda flakey. The build in Atheros chipset is running (by default) in power save mode. Which will limit it's sending strength to 20~30mW instead of the full 100mW... this is to raise some longer battery life.

20~30mW should be more than fine if you aren't in a 802.11 crowded area, or not being outdoor. But even with 20~30mW you should be capable to (at least) bridge something like 10-30 meters (depending on your location).

What I would advise you to do is the following:

Go and download NetStumbler (www.netstumbler.org), and start analyzing your AP from all corners of your wireless toplogy. Double click your ESSID and check the SNR (signal to noise ratio). If you have gotten your signal to noise ratio, the amount of watts of your WirelessNIC & the strength of your AP + reception sensititvity you take these numbers into account and visit the following website:

www.swisswireless.org/wlan_calc_en.html

here  you will have a link-budget-calculator. Fill this one in (and use the formulas accordingly), in order to verify if your current signla + background noise is allowing you a steady connection.

Should this be too much effort, I can only give you the following golden rule:

Your AP should be seperated from the most strongest surrounding APs by at least 5 channels. If you are living in an erea in which radio echos aren't unlikely (apartment with re-enforced concrete walls) then set your pre-amble to short. And try lowering the output of your AP (in mW).

I can guarantee you that almost 80% of all 802.11 problems exist only due to a bad implementation of your wireless infrastructure. Or environmental variables which had not been taken into concideration during the implementation (I.e. other microwave emitters, high-power lines, heavy electrical machinery, radar or re-enforced conrete).


I hope that this might help you (and others) out, if you have any questions: Just drop me a line or two ;)


  Reply Reply Quote & Reply Quote & Reply
The EU: Worth 4400mAh The rest of the world... Enjoys mobile computing!
Old Skool
VIP Member
Posts : 4
Level :
Tech Points : 0
From: United States
Posted:7/30/2008 11:28:00 AM # 3


Quote:
Author: jeffsiegel Posted: 7/10/2008 2:32:00 AM

I can't get a wireless connection, and I get the same error codes as everyone else who has posted here. I have tried all the solutions (except going into the / and /home directories, which don't appear to be the same on my 900 as on the machine mentioned in the post).

Does anyone else have any thoughts? Do I need to return the 900?

And, for what it's worth, the 900 won't read my multimedias card, either.

I had a problem where DHCP (dynamic host configuration protocol) would fail on the EEE 900-Linux when using a wireless access point with WEP or WPA encryption. That would lead to an infinite "pending" state.

My original fix was to use a static address, which is a major pain. However, by installing the atheros-swan-modules-2.6.21.4-eeepc (atheros driver) version 20080315-1 from the p701 repository, and updated to the latest xandros-wpa-supplicant program, I fixed the problem. The atheros version that shipped with my Eee 900 was 20070925-4 (which is the only one in the p900 repository), and the wpa-supplicant was 0.5.7.x.2.17-1.

To get the update, you need to run the synaptic program and temporarily add the p701 (Eee PC 701) repository at:
  •   URI: http://update.eeepc.asus.com/p701/testing
  •   Distribution: p701
  •   Section: main

And then update to the 20080315-1 version of the driver. From the same repository, update the xandros-wpa-supplicant to version 0.5.7.x.3.1-1. Finally, remove the p701 repository.  [I believe you could probably do the same thing with apt-get instead of synaptic.]

Anyway, I applied this update to my EEE 900 and to one owned by a friend. We had both been having the dreaded "pending" problem caused by the DHCP failure. After applying this fix, both of our systems' encrypted wireless connections just work.

I think the upgraded driver should be made available to Eee 900 Linux users by Asus in the standard p900 repository.



Step by step instructions to update using synaptic to fix a broken wireless network:
  1. Type "Ctrl+Alt+t" to get a shell window
  2. In the shell window, type "sudo synaptic"
  3. Using synaptic's UI, use "Search" to look for "atheros"
  4. Verify the "Installed Version" for atheros-swan-modules-2.6.21.4-eeepc is 20070925-4
  5. In "Settings->Repositories", add the p701 listed above
  6. Press "Reload" to get the repository information
  7. Verify the "Latest Version" for atheros has 20080315-1
  8. Right-click on the atheros listing to mark for upgrade
  9. Search for "wpa"
  10. Verify the "Latest Version" for xandros-wpa-supplicant is 0.5.7.x.3.1-1
  11. Right-click on the xandros-wpa-supplicant listing to mark for upgrade
  12. Press "Apply"
  13. When done, go to "Settings->Repositories" and remove the p701 repository you added in step 5


 

  Reply Reply Quote & Reply Quote & Reply
gunhero
Member
Posts : 1
Level :
Tech Points : 0
From: Sweden
Posted:8/1/2008 4:34:00 AM # 4
I have done this step by step several times.

It does NOT work for me.

  Reply Reply Quote & Reply Quote & Reply
Old Skool
VIP Member
Posts : 4
Level :
Tech Points : 0
From: United States
Posted:8/1/2008 3:00:00 PM # 5

Quote:
Author: gunhero Posted: 8/1/2008 4:34:00 AM

I have done this step by step several times.

It does NOT work for me.

Question: Did the process not work to get the updated software, or did your wireless connection still not work with the updates installed?

By the way, there is a similar thread on the EeeUser forum:

http://forum.eeeuser.com/viewtopic.php?id=25425&p=3



In any case, if all else fails, it is possible to set up a static IP address for accessing a WPA protected access point. It's a bit of a pain, but it seems to be completely reliable.  To do that:
  1. Determine an unused IP address in the subnet. If you have administrative access to the router/access point, you can see what IP addresses it will give out via DHCP. Just pick an unused address outside that range but in the same subnet. If you don't have administrative access, you can usually guess a safe address by having another PC connect to the access point and determine its address (Start->run->command and in the window type "ipconfig"). Pick an address well away from the one given to the PC.
  2. In the EEE's network tool, Create a new connection as follows:
  3. Under the Wireless tab, put in the SSID (name) of the wireless access point and the encryption type and key. Other fields can be left at Auto/Any.
  4. Under TCP/IP tab, put chosen in the IP address from step 1, and the subnet mask from the PC or the access point's configuration. Set the Access point address as your gateway.
  5. Under the DNS tab, you can usually give the access point/router's IP address as the DNS server. However, some units will not act as a DNS proxy. If that happens, you will see the network become Enabled, but will still not be able to access outside web sites. In that case, you will have to copy the external DNS server used by the PC or the one from the access point's administrative status page.
  6. Press OK.
If all went well, you should be able to use the Connection->Connect menu to start the network.

  Reply Reply Quote & Reply Quote & Reply

Posts :
Level :
Tech Points : 0
From:
Posted:8/9/2008 4:49:00 AM # 6
When attempting to connnect to a network you should be able to click the details button to get more info.

Could you please do that and copy and paste the results here?.

Quote:
Author: gunhero Posted: 8/1/2008 4:34:00 AM

I have done this step by step several times.

It does NOT work for me.


  Reply Reply Quote & Reply Quote & Reply
Libbe
Member
Posts : 1
Level :
Tech Points : 0
From: Norway
Posted:8/27/2008 9:41:00 PM # 7

I tried upgrading both packages on my 900, but now my wireless isn't working at all. I can't find any networks.

I also seem to have both ath0 and wifi0 connection. Should I have both?

I should also mention that installing the original versions of those files, does not help.

  Reply Reply Quote & Reply Quote & Reply
Pandolfini
VIP Member
Posts : 2
Level :
Tech Points : 0
From: Italy
Posted:9/23/2008 2:54:00 AM # 8
I had the same connection problems but after installing the new atheros drivers as descripted above I solved the problem.

I HAVE NOTICED that sometimes the connections management program tries to connect to connections others than the wanted one... For example although I wanted to connect to my home's WAN, It tried to connect to my office's one... I have not ha solution to this problem but I signal IT.

  Reply Reply Quote & Reply Quote & Reply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.