SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > Crosshair II Formula  
  Forum  
  Topic : [Problem]ASUS Crosshair Formula II - SATA and other problems New Topic
troop
Member
Posts : 12
Level :
Tech Points : 0
From: Germany
Posted:7/7/2008 4:22:00 AM # 1
Hi there

Bought this MB for outstanding features and due to very good experiences with the
M2N32-SLI Deluxe.
Updated to BIOS 0701 right away and plugged in my Phenom 9850 BE (non-oc everything)

I have the same problems as already reported; OCZ PC8500 DDR2 1066 CL5 XTC Platinium
8GB in total, unganged mode. Timings are not displayed correctly in BIOS, but in CPU-Z 1.46
Does not matter, if SLI-ready is set, or timings put in manually
(5-5-5-18-26-2T @1066@2.1V)

For DDR800 memory limit, timings are shown correct in BIOS and CPU-Z.
-

Ok, now for my problems(2 actually) with the MB.

I did installed Vista x64 Ultimate ( + all updates + SP1) and Vista found the VelocyRaptor on
SATA 1, installing happily. BIOS is set to 'IDE' mode for SATA, not AHCI !

I did *not* install the chipsetpackage off the DVD, Version 18.08, but an slightly newer one,
18.11
The IDE-SATA driver is *not* included in these two mentioned packages(!), *only* the
AHCI drivers are. Why?

First problem: As soon as I install an >IDE-SATA< driver(.998) on the controller and reboot,
I may get an BSOD (7b error) *or* the painfull 'winload.exe' (221) or 'ntoskrnl.exe' (428)
are corrupt - messages upon Vista startup. Needs the DVD to repair and thankfully, that works out as
of yet. (I have tried to install the IDE-SATA drivers 3 times; result always failure)
Questions for this specific problem: Is there any >IDE-SATA< Nvidia driver, known to be working with
this MB? Or is it only possible to switch to AHCI in BIOS and reinstall Vista with these drivers?
-
Second problem: In device manager, I get one 'coprocessor' with yellow exclamation mark
displayed(Other devices), for which no driver can be found? The Phenom 9850 BE however,
is displayed correctly under 'Processors' (x4, as it should)
-
Plus, I get one 'unknown device' with yellow exclamation mark
displayed(Other devices), for which no driver can be found

Everything else is found and drivers installed for (Standard Dual channel PCI IDE controller,
for example) Does anyone around here have the same problems or does know the correct drivers/software
to be installed to remedy these problems? Thank you very much.

troop

PS: I love this MB. Note to fellow users, I also had startup problems using an 400W PSU with not
even the GFX-card installed (8800GTS; G92) using onboard VGA only and 2 drives, HDD and DVD-RW.
Once the 700W beQuit Dark Power Pro was hooked up > everything well. This MB needs a *lot and
stable* juice to begin with, literally. :)

  Reply Reply Quote & Reply Quote & Reply
troop
Member
Posts : 12
Level :
Tech Points : 0
From: Germany
Posted:7/10/2008 1:29:00 AM # 2
Ok, Problem 1 was solved this way:

0. Dont do *any* of this without an complete Image of your HDD.
1. Installed Silicon Image SATA Controller and drivers for it.
2. Shutdown and hook up VelociRaptor on that one, boot.
3. Vista was deactivated in the process (if I ever meet the person, who decided that crap,
I'll do harm to him, I swear)
4. Installed standard Microsoft AHCI 1.0 driver on one of the 'Standard Dual PCI-IDE controllers'
shown in device manager. You need to do an force-install. Unfortunally, you cannot see which one is
the correct one for the SATA ports.
5. Reboot into BIOS and switch to AHCI mode on the MCP IDE setup.
6. Reboot into Vista and make sure, one of the 'Standard Dual PCI-IDE controllers' is
shown without yellow exclamation mark;..if it is, then you installed the Microsoft AHCI 1.0 driver
onto the wrong port. (In that case, rollback the driver and install the AHCI driver on the other port
shown. It *must* read 'Standard AHCI 1.0 Serial ATA' controller)
7. Now I manually installed the Nvidia SataIDE Driver (v10.3.0.21) WHQL from chipset package 18.11
over the Microsoft standard AHCI 1.0 one.
8. Reboot and make sure(!) the driver is shown correctly in device manager!
9. Finally, shut down and rehook your HDD onto the MB SATA port.
10. On next shutdown, I removed the Silicon Image controller.
11. Reactivate.
-
I was unable to get the above done without this SiL controller. Warning, it is not possible to
accomplish the above using SATA HDDs on the onboard ports only, because you cannot install
2 different drivers onto the controller;..Vista just craps out then at reboot.
-
Another workaround would be to image the OS drive to an PATA HDD, install the needed AHCI
controller driver, then image the OS drive back from PATA to SATA HDD.
(Mind you, I started out with SATA set in *IDE* mode and was unable to install an Nvidia SATA-IDE
driver without BSOD or Data corruption at Vista startup;..thus the fuss)

Well, it works :)

Problem 2 was solved by manually installing the 'SMU' driver from the chipset package
18.11 onto the 'coprocessor'. Anyone explain to me, why Vista does not take 'WHQL' signed drivers,
if you install them the normal way by running their setup? *Also* missing was the driver for
'Nforce Hypertransport Bridge' (Vista installed some standard PCI bridge crap) and this one alone
could cost you a LOT of performance, so make sure, it got installed or install manually.

Still, I got one 'Unknow device' left.

I dont know why this happens;..but the chipset drivers of Nvidia do *not* install
correctly on Vista (Setup 'Run as Administrator') I had very little problems with all
(ASUS-) MBs + Nvidia chipset packages installations on *XP*..Vista is....different.

Above all, have fun! :)

  Reply Reply Quote & Reply Quote & Reply
troop
Member
Posts : 12
Level :
Tech Points : 0
From: Germany
Posted:7/11/2008 5:20:00 AM # 3
'Unknow device' error solved as well.

It was ASUS LIVE! enabled in Bios. (I dont use it)
Once disabled, no more unknow device. heh.

  Reply Reply Quote & Reply Quote & Reply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.