SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > P5K3 Deluxe  
  Forum  
  Topic : [Problem]ASloader.exe and AScenter.exe behaviour under Vista New Topic
Halo Jones
Member
Posts : 22
Level :
Tech Points : 32
From: United Kingdom
Posted:11/8/2007 9:21:00 AM # 11
Thx Steve, found that now, will sort their disbaling in task schedule under an admin login tomorrow.  Has anyone found any information on exactly what these two processes report to actually do yet?

  Reply Reply Quote & Reply Quote & Reply
MightyGuru
VIP Member
Posts : 1
Level :
Tech Points : 0
From: United States
Posted:11/23/2007 1:48:00 PM # 12
I just hit this problem with my new computer. Even if my computer is based on Formula Maximus motherboard, the issue is the same since it relates to Asus software.
The tasks are run through Task Scheduler (under Accessories-System Tools). If you unfold Task Scheduler Library, there is a group called Asus with 3 tasks: aaCenter.exe, AsLoader.exe, and CpuLevelUpHookLaunch.exe. Each of these tasks is scheduled to run with highest priviliges and that causes the warnings when logging on to non-administrative accounts.
The purpose of the tasks in not completely clear, but they are a part of Asus power management. I guess they provide hookups for utilities like AI Suite to communicate back with ACPI services, even when AI Suite is not running. This is supported by the fact, that AI Suite cannot be started on non-administrative acconts.
Unfortunately, these tasks must be run elevated to perform their duty. If we accept that automated power management is available only to administrative accounts, the problem can be resolved by NOT RUNNING the tasks on the REGULAR user accounts. This can be done by editing the tasks in Task Scheduler. However, just setting the tasks to start when administrators log on didn't work for me. The tasks didn't start (I wouldn't be surprised if this is a Vista bug). But when I set them to start for the specific (administrative) account, it all worked as expected.
As an added bonus, AI Suite suddenly started working on non-administrative accounts. It may not be fully functional, but a least I get the temperature and voltage readouts.

  Reply Reply Quote & Reply Quote & Reply
Robus
VIP Member
Posts : 1
Level :
Tech Points : 0
From: Netherlands
Posted:9/24/2008 4:30:00 PM # 13

This weekend I assembled my computer and ran into some trouble as I set up another user account. When switching to this account I get asked for admin-permission to run the AsLoader. When I do so the computer/CPU gets hogged by seemingly AsLoader and/or AsCentre. Furthermore I also notice a flickering Splendid-logo in the upper right hand of my desktop.

I previously installed PC Probe2 which came with my P5Q Deluxe Mobo as well as updating the Asus BIOS by running Asus Update. Also installed GamerOSD and Asus Smartdoctor which came with the vidcard. Since I thought they were the cause of my problems in the user account, I deinstalled both Probe2 and Smartdoctor, but the problem still persists.

I read somewhere that deinstalling Smartdoctor and Probe still leaves AsLoader and/or AsCentre on your computer and you should remove the AsLoader file from the Asus folder manually after rebooting Vista in Safe Mode.
This seems somewhat drastic to me. Any ideas?

  Reply Reply Quote & Reply Quote & Reply
Asus P5Q Deluxe, Intel Core2Duo 8500 3,16Ghz, Asus ENGTX260HTDP/896Mb, Corsair 4096MB XMS-26400 DDR2 800Mhz Lat 5-5-5 18 Twinx, Samsung F1 1TB, Vista Home Premium 64, Asus Silent Knight AL
bbbl67
VIP Member
Posts : 23
Level :
Tech Points : 40
From: Canada
Posted:4/2/2011 9:51:00 AM # 14
Here's the solution:

Specifically what you can do to disable this from loading is to go into the Windows Task Scheduler (Control Panel - Administrative Tools - Task Scheduler). Click on "Task Scheduler Library", and you'll see a folder called "ASUS". Right click on the item "ASUS RegRun Loader", and click "Disable". That's it.

At least that's the case under Windows 7. But I assume it would be the same under Vista and future versions too.

  Reply Reply Quote & Reply Quote & Reply
Jose A
Member
Posts : 1
Level :
Tech Points : 1
From: Spain
Posted:1/10/2012 3:17:00 AM # 15
If you don't want to disable the task, you can set it to run with the credentials of an administrator account.

Go to 'Control Panel' - 'Admin Tools' - 'Task Scheduler' - . Once you are in the Task_Scheduler, in the left panel there is an ASUS folder - click the folder - in the right panel you will see "ASUS RegRun Loader"- right click - go to 'Properties'. In the 'General' tab, you'll see in the lower half a section called 'Security options' Left click on 'Change user' and type in the name of an account with admin privileges. Then go to the button below and change it to 'Run whether user is logged in or not'. Leave the 'Do not store password' checkbox unchecked... we don't want a password prompt!

Now click 'Ok'. You should now get a prompt for the admin-level account's password. Enter it and click 'Ok' again.

The task will still run, but now other users won't see it any more!

Alternately, if you just want to turn it off for other users, do as above up until the button bellow. Set this as 'Run only when user is logged in' and the task will only run for the account you named.

  Reply Reply Quote & Reply Quote & Reply
First  Prev  1 2
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: Ulrich New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.