SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Audio Cards  
  Forum  
  Topic : [Problem]Plug-in your Asus Xonar D2 audio device! New Topic
Gartner
Member
Posts : 3
Level :
Tech Points : 0
From: United Kingdom
Posted:3/8/2008 2:35:00 AM # 1
Hello,

Recently bought an Asus Xonar D2 for my vista 64 machine after reading its excellent reviews on vista and can not for the life of me get it installed or even recognised by windows.

The lights come on the card and it feels warm, looks like its operating fine.

I have read a couple fixes by changing the config files in the drivers from DX to D2, but all of mine are correct and point to the D2 so that fix seems out.

I have reinstalled windows and it still wont even let windows recognise it.

What I have tried ..

Installing from disk via autoplay - "Please plug-in Asus Xonar D2 audio device!"

Installing from EVERY downloadable version online - Same error.

Attempting to install via add hardware "No drivers compatable with your system, make sure they are x64 compatable"

Switched to a 2nd PCI slot - Same errors

Attempted installing in safe mode - Same error

Re attempted installing via Add hardware, scrolled to the /driver or /Software folder and tried via that .inf, started to load and then each time gives me a BSOD pointing to "CMUDAXP.SYS" .Upon reboot, it recognises the card under device manager but says "Windows cannot load the device driver. It may be corupt or missing" Continues to be unstable until I remove it.

Kicking the PC ..... nothing happened


Additional Infomation -

Q6700 - 3Ghz
EVGA 680i sli
2x 8800 GTX
4 gb RAM
Vista 64 ultimate

At the end of the road here, anything else I could try ? Otherwise I have an RMA number for a refund already arranged.

sincerely

a Former Creative user who migrated to ASUS hoping for quality

  Reply Reply Quote & Reply Quote & Reply
Gartner
Member
Posts : 3
Level :
Tech Points : 0
From: United Kingdom
Posted:3/8/2008 3:14:00 AM # 2
UPDATE

Wont install on Vista 32 either but becomes recognised and installs fine on Windows XP 32 bit .. so much for vista ready.

  Reply Reply Quote & Reply Quote & Reply
Gartner
Member
Posts : 3
Level :
Tech Points : 0
From: United Kingdom
Posted:3/9/2008 2:56:00 AM # 3
After messing another day with it, I have gotten the card to be listed under device manager by trying to install via "add hardware" and loading the driver/pci/xonarD2.inf where every time the PC will BSOD pointing to cmudaxp.sys.

Once rebooted, the Xonar shows on the device list as " Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39) "

Here is a log of a windows error report

Product
ASUS Xonar D2 Audio Device

Problem
Could not load driver software

Date
08/03/2008 16:39

Status
Not Reported

Description
Windows was able to successfully install device driver software, but the driver software encountered a problem when it tried to run. The problem code is 39.

Problem signature
Problem Event Name:    PnPDeviceProblemCode
Architecture:    x64
Hardware Id:    pci\ven_13f6&dev_8788&subsys_82691043
Setup class GUID:    {4d36e96c-e325-11ce-bfc1-08002be10318}
PnP problem code:    00000027
Driver name:    cmudaxp.sys
Driver version:    5.12.1.8
Driver date:    01-30-2008
OS Version:    6.0.6000.2.0.0.256.1
Locale ID:    2057

Files that help describe the problem
DMI7EC4.tmp.log.xml
LOG7EC5.tmp
oem14.inf


and windows dump

Microsoft (R) Windows Debugger Version 6.8.0004.0 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\Minidump\Mini030808-02.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Invalid directory table base value 0x0
Mini Kernel Dump does not have process information
Symbol search path is: SRV*C:Symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows Vista Kernel Version 6000 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 6000.16584.amd64fre.vista_gdr.071023-1545
Kernel base = 0xfffff800`01c00000 PsLoadedModuleList = 0xfffff800`01d9af70
Debug session time: Sat Mar  8 18:04:23.685 2008 (GMT+0)
System Uptime: 0 days 0:13:43.807
Loading Kernel Symbols
.........................................
Loading User Symbols
Loading unloaded module list
.
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 7E, {ffffffffc0000005, fffff9802d3e9180, fffff98001271888, fffff98001271260}



Probably caused by : ntkrnlmp.exe ( nt!EtwTraceContextSwap+17d )

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff9802d3e9180, The address that the exception occurred at
Arg3: fffff98001271888, Exception Record Address
Arg4: fffff98001271260, Context Record Address

Debugging Details:
------------------




EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

FAULTING_IP:
+fffff9802d3e9180
fffff980`2d3e9180 ??              ???

EXCEPTION_RECORD:  fffff98001271888 -- (.exr 0xfffff98001271888)
Cannot read Exception record @ fffff98001271888

CONTEXT:  fffff98001271260 -- (.cxr 0xfffff98001271260)
Unable to read context, Win32 error 0n30

CUSTOMER_CRASH_COUNT:  2

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x7E

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from fffff800020e7e5c to fffff800020e4caf

STACK_TEXT: 
fffff800`02d75ca8 fffff800`020e7e5c : 00000004`8000004c fffffa80`0472e6d0 00000000`00000002 fffff800`020e7e5c : hal!HalpQueryHpetCount+0x23
fffff800`02d75cb0 fffff800`01cedc3d : fffff800`02d75cf8 00000000`00000018 fffff800`01d4e120 fffff980`04238bb9 : hal!KeQueryPerformanceCounter+0x30
fffff800`02d75ce0 fffff800`01c501cf : fffff800`01d4a980 00000004`cba9d8f2 fffff800`02d6f070 fffff800`01d50400 : nt!EtwTraceContextSwap+0x17d
fffff800`02d75d40 fffff800`01c4fcc6 : 00000000`00000001 fffff800`01d4fc80 fffffa80`093cef40 fffff800`01d4fc80 : nt!SwapContext+0x16f
fffff800`02d75d80 fffff800`01e00724 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0xf6
fffff800`02d75db0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemStartup+0x1d4


FOLLOWUP_IP:
nt!EtwTraceContextSwap+17d
fffff800`01cedc3d 448b8790000000  mov     r8d,dword ptr [rdi+90h]

SYMBOL_STACK_INDEX:  2

SYMBOL_NAME:  nt!EtwTraceContextSwap+17d

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  471ea8dd

STACK_COMMAND:  .cxr 0xfffff98001271260 ; kb

FAILURE_BUCKET_ID:  X64_0x7E_nt!EtwTraceContextSwap+17d

BUCKET_ID:  X64_0x7E_nt!EtwTraceContextSwap+17d

Followup: MachineOwner
---------



Please asus with your rock solid and heart touching support... dont rush. 1 at a time.


  Reply Reply Quote & Reply Quote & Reply
Ted
Member
Posts : 13
Level :
Tech Points : 0
From: TAIWAN, R.O.C.
Posted:3/19/2008 12:28:00 PM # 4
could you get the vendor ID device ID, subVendor Id, Sub device ID to me.
it seems the ID isn't correct in your sound card.

  Reply Reply Quote & Reply Quote & Reply
cladisch
VIP Member
Posts : 804
Level :
Tech Points : 465
From: Germany
Posted:3/19/2008 6:41:00 PM # 5
The IDs are listed in Gartner's post, under "Hardware Id".

13F6:8788, 1043:8269 is correct for a Xonar D2.

  Reply Reply Quote & Reply Quote & Reply
chandab
Member
Posts : 4
Level :
Tech Points : 0
From: Australia
Posted:9/20/2008 7:53:00 AM # 6
hey man did u end up fixing ht problem because i have the same exact issue

  Reply Reply Quote & Reply Quote & Reply

Posts :
Level :
Tech Points : 46
From:
Posted:6/1/2009 10:03:00 AM # 7
Why the official support of Asus didn´t says anything?
style="TEXT-ALIGN: left" dir=ltr id=result_box>A person buying an expensive card, does not work, ask for help in the official forum and does not help?
Great support asus great.

I got a erro like that... what I did:

Installed a old cd driver and made a manual update with the last web driver.

Advanced system settings->Hardware->Device Manager->click in audio device->
Update driver->Browse my computer->Let me pick from a list.. ->Have a disk->
( last drive \SoftwareDriver\Driver\XonarD2.inf)
Accept
If the os ask you about wrong driver ignore.

  Reply Reply Quote & Reply Quote & Reply
heuan
Member
Posts : 1
Level :
Tech Points : 1
From: Heard and Mc Donald Islands
Posted:6/14/2009 8:30:00 PM # 8

> Installing from disk via autoplay - "Please plug-in Asus Xonar D2 audio device!"

humm i had this error message with xp64 after i tried installing a linux distro a while ago, there are posts that describe similar problems (but i can't be bothered to find them for you)

anyway one of the posts on this forum linked to this: http://www.alsa-project.org/main/index.php/Xonar_EEPROM_Failure and it worked for me (i just used an ubuntu live cd but it says you can use dos)

  Reply Reply Quote & Reply Quote & Reply
Hysterian
Member
Posts : 1
Level :
Tech Points : 1
From: Botswana
Posted:6/21/2009 12:48:00 AM # 9
same problem too, but diference.... dx works well d2x has error message on vista 64 with formula maximus...... eeprom on my d2x is good, there is no bug. If I give xonar his driver without a chance, he write that they will no work fine, but they works well. but i havent an asus audio console and this is a problem for me :(

  Reply Reply Quote & Reply Quote & Reply
Noah
Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:7/18/2009 10:55:00 PM # 10
Long story short, I don't have a d2, I have an Asus Xonar HDAV1.3 Deluxe.  But I had similar issues, and received the "Please Plug-in ASUS Xonar HDAV Device" message.  I also noticed that in device manager there was a PCI express to pci /PCI X Bridge thingy that couldn't find enough resources to start, I think this might have been part of the Xonar card that was being seen only partially by the system. I tried the iso device id check as suggested later in this thread, and it showed all of the right EEPROM info, so that was not my issue.
 I have the same motherboard as the previous post an EVGA 680i SLI and also have Vista 64.  However the problem was with the BIOS.  I was running the P31 BIOS from EVGA, and had taken the approach of "if it ain't broken, don't fix it". 
This was definitely broken, so what I did:
1: Go to EVGA.com and download the now current P33 BIOS in ISO format
2: Burn the ISO to a blank CD ( I used nero 8)
3: Reboot, press DEL to enter BIOS, PUT IN BIOS CD, Set Defaults and press F10(Save and Exit)
4: Disc should automatically start, but you may have to press a key on the keyboard to boot from CD, Follow the instructions...takes less than a minute. Reboot
5: Press DEL to enter BIOS again, and fix all of the settings that were screwed up by step 3, i.e. Voltages, timings, overclocks, etc. f10 and reboot.
6: Windows will load and find the device, DO NOT LET IT SEARCH FOR DRIVERS.  CANCEL THE DRIVER WINDOW AND RE-RUN THE ASUS DRIVER SOFTWARE.
7: Breathe.
8: Spend next week setting up Total Media Theatre....

At this point I had the Xonar working, but Arcsoft Total Media Theater was another issue altogether.  I had previously been using TMT2 full version before ever buying the Xonar HDAV, and it would not recognise the HDMI.  However a special version of TMT2 is included with the Xonar HDAV1.3 Deluxe that will supposedly enable full HDMI support.  I could never get it to work, even after 8 straight hours of monkeying around with it.  So I re installed the included ASUS TMT2 Version, rebooted, went to arcsoft connect from the start menu, registered the software, copied the serial to the clipboard, went to arcsofts website and used that serial to upgrade to Total Media Theatre 3 Platinum for $49.99.  I uninstalled the ASUS TMT2 and then Installed TMT3, and now everything works right.  The drivers took a little bit of fooling around with to figure out, but I ultimately had to use the notification area icon to change the driver to HDMI, independently of the Windows Driver settings that you set in the Sound section of the Control Panel which have to be set as well.  Then contrary to other posts, I had TMT3 set to HDMI, not HDMI passthough.  This way the Receiver would properly receive the native DTS-HD-MA and DOLBY-HD.  At the time of this post I've had the card a grand total of 3 evenings, and had it working for a total of 12 hours, including last nights sleep, After watching Valkyrie on Blu-Ray

HARDWARE:
Intel Q6600 2.4 Running at 3.6 with 8x multiplier
EVGA 680i SLI  P33 BIOS
EVGA 8500GT on PCI-x16 slot 1
2x1GB OCZ 1066 SLI (EPP) Memory
ASUS Xonar HDAV1.3 Deluxe PCI-x1 onPCI-x16 slot 3
LG Blu-Ray ROM / HD-DVD ROM / DVD Burner
LG DVD Multi-format Burner (to keep my bluray drive from being whored out for everyday tasks.
Onkyo SR-706 THX Certified 7.1 Tuner
Panasonic TH-58Z800U 58" Plasma THX Certified Flat Panel on Sanus Systems Articulating wall mount

SOFTWARE:
Windows Vista Home Premium 64bit
SlySoft AnyDVD HD
SlySoft Virtual CloneDrive
ArcSoft Total Media Theater 3 Platinum

This was thrown to together offsite from what I remembered from the installation experience, so please forgive any errors and or omissions.  I figured it was about time I quit using everybody elses posts without contributing when I had a chance.  and since there wasn't much information on this topic I felt even more inclined to post.  Thanks again to all those posters that have helped me though my computer issues in the past.

PLEASE READ MY NEXT REPLY...It corrects some mis information in this post. It's post #12 on the next page.

  Reply Reply Quote & Reply Quote & Reply
1 2  Next  Last
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: yoyolai New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.