SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Wireless > RT-N66U (VER.B1)  
  Forum  
  Topic : [Problem]Can't connect to 5GHz band New Topic
Jay
Posts : 25
Level :
Tech Points : 44
From: United States
Posted:5/2/2012 9:48:00 AM # 1
Had this router for about a week now and more than happy with it. My only problem is I have 2 devices that can see the 5GHz band but can not connect to it. If a device can find a 5GHz band shouldn't it be able to connect to it? Every time I try to connect it says password is incorrect or adapter settings are invalid. I am positive my password is correct and how can the adapter settings be invalid what ever that means.

  Reply Reply Quote & Reply Quote & Reply
Taurean75
Posts : 139
Level :
Tech Points : 193
From: United States
Posted:5/2/2012 11:07:00 AM # 2
Make sure your adapter supports 802.11n and 5GHz band.  I personally use an USB-N53 with no problem.

  Reply Reply Quote & Reply Quote & Reply
Michael
mikeg
VIP Member
Posts : 277
Level :
Tech Points : 221
From: Sweden
Posted:5/2/2012 10:26:00 PM # 3

Quote:
Author: Taurean75 Posted: 5/2/2012 11:07:00 AM

Make sure your adapter supports 802.11n and 5GHz band.  I personally use an USB-N53 with no problem.

I use two USB-N53:s too and my Dell inspiron with a built-in wireless works too on 5 GHz but
a Dlink DWA-160 did not work at all - had to send it back RMA. You can be one of the unlucky
ones with a faulty unit : I had to replace mine and the third one works.

  Reply Reply Quote & Reply Quote & Reply
dtd3cebu
VIP Member
Posts : 16
Level :
Tech Points : 3
From: United States
Posted:5/3/2012 5:02:00 AM # 4
Try without security and see if you can connect then go from there. Otherwise try  to reset to default after a firmware upgrade then try again. WPA  didn't work for me and it took me a while to figure it out.

  Reply Reply Quote & Reply Quote & Reply
Jay
Posts : 25
Level :
Tech Points : 44
From: United States
Posted:5/4/2012 7:21:00 AM # 5
I got my Toshiba Blu-Ray player connected finally on the 5GHz band. My Xbox 360 with it's wireless N adapter can see the 5GHz network but can't connect to it. I even tried switching the channel band from 40MHz only to 20/40Mhz auto and it still doesn't work. I just gave up and connected to the 2.4GHz band and it works perfectly.

  Reply Reply Quote & Reply Quote & Reply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: HHC New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.