SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > P8P67 PRO (REV 3.1)  
  Forum  
  Topic : [Problem]Windows 7 64 Bit install in "Raid Mode" New Topic
Kenneth
Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:7/25/2011 7:27:00 AM # 1
I have recently installed Windows 7 Pro 64 bit on a single SATA 3 hard drive. I am looking to add two drives for video editing. I would like to stripe the drives Raid 0, however, when I looked at the ASUS manual for doing so, it said all drives need to be either Raid or AHCI. If I change the mode to Raid in the BIOS, then of course Windows will fail to load. So my questions are as follows:

1) Can I convert Windows from AHCI mode to Raid mode without re-installing?
2) If I have to re-install, how difficult is it to do with this motherboard, and what are the steps?
3) I have used windows on another computer to create a raid, can I keep the drives in AHCI mode and have the Windows software create the Raid for the two new drives?

Any help in this matter would be greatly appreciated.

Thanks

  Reply Reply Quote & Reply Quote & Reply
Kenneth
Member
Posts : 2
Level :
Tech Points : 1
From: United States
Posted:7/26/2011 12:14:00 AM # 2
OK, So after some looking around I came across the following info that I found helpful:

"Working with an ASUS P8P67 Pro Rev 3 motherboard, BIOS version 1502.

I had problems getting Windows 7 Ultimate 64 bit to install to a 3 TB disk. The first couple of times I tried, I ended up with:

  1. A 100 MB "System Reserved" partition
  2. A 2047 GB "Primary" partition
  3. A  749 GB unallocated space

The "diskpart" utility indicated that the partition was MBR format. The 749 GB unallocated space was not usable - all "Actions" in Windows Disk Manager were disabled.

Here's what worked for the system described above:

With the Windows 7 install disk in the DVD drive, I restarted the computer and entered the BIOS utility. At the bottom of the screen, there was a "Boot Priority" section. It showed 3 icons:

  1. A UEFI icon on the DVD
  2. A non-UEFI icon on the DVD
  3. The hard disk drive

WHEN I BOOTED WITHOUT THE WINDOWS 7 INSTALLATION DISK IN THE DVD DRIVE, THERE WAS NO UEFI ICON IN THE BOOT PRIORITY LIST.

I re-arranged the icons so that the UEFI icon was first, followed by the non-UEFI icon and then the hard disk icon. Selected "Save changes and exit." and rebooted from DVD.

Windows setup started. Did shift-F10 at the "Enter languages ..." screen. Used diskpart:

  1. select disk 0
  2. clean
  3. convert gpt
  4. list disk

Got "Successfully converted to GPT" message after step 3. Step 4 showed a single partition with an asterisk in the "GPT" column. Continued with the installation. The "Where do you want to install Windows?" screen showed Disk 0 with a single 2794.5 GB unallocated space. I choose this unallocated space and clicked "Next". The installation started copying windows files.

After installation, diskpart "list partition" showed 3 partitions:

  1. A  100 MB "System" partition
  2. A  128 MB "Reserved" partition
  3. A 2794 GB "Primary" partition

diskpart "list disk" showed 1 disk with an active GPT partition:

Microsoft DiskPart version 6.1.7600
Copyright (C) 1999-2008 Microsoft Corporation.
On computer: P8P67R3

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
* Disk 0    Online         2794 GB      0 B        *

Windows' "Disk Management" graphical interface showed 2 partitions:

  1.  100 MB "Healthy (EFI System Partition)"
  2. 2794.3 GB "Healthy (Boot, Page File, ... Primary Partition)"

I have since installed all the drivers needed and run Windows Update to install about 100 updates. Needless to say, there were many reboots during that process. So far, the only problem I've discovered is that an attempt to use Windows Backup to save a system image fails with the message, "Volumes larger than 2088958 megabytes cannot be protected.", error code 0x807800B4. I've opened a trouble ticket and am working with Windows support to resolve this issue."

I did unfortunately end up re-installing my OS, though it seems you can run a single drive on the raid controller (though it is not technically a raid). And the install went pretty smoothly. Hope this may help others who wish to run in RAID mode.


  Reply Reply Quote & Reply Quote & Reply
Chillwill
Posts : 1
Level :
Tech Points : 1
From: Norway
Posted:8/11/2011 11:05:00 PM # 3
If you wanna set up disks in raid with disks over 2.2tb you need to update your bios to ver 1704 and install the newest 10.5 IRST drivers. So if you are installing windows with a 3tb disk attached you wanna set sata mode to AHCI mode until you get bios and sata drivers updated. Then you can set up raid mode.

  Reply Reply Quote & Reply Quote & Reply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.