SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > P8H77-M PRO  
  Forum  
  Topic : [Problem]Fan Xpert New Topic
LunaRadish
Posts : 1
Level :
Tech Points : 1
From: United States
Posted:5/9/2012 2:59:00 PM # 1
I recently purchased and used a P8H77-M Pro motherboard in my new PC.

initially, Fan Xpert in Asus Suite II worked wonderfully. now it will not load, at all. when I attempt to load Fan Xpert I get this error:

server execution failed, ProgID: AsusFanControlService.FanControlManager

if I click "test" (as after this error occurs, the tab for Fan Xpert is sometimes available, but it's a blank window where the controls should be), I get this error:

Assertion Failed: Isbound (), file C:\Builds\TP\emuvcl\utilcls.h, line 3606

no amount of reinstalling fixes it. I removed the battery on the motherboard and replaced it to reset the BIOS. this did not fix it as well.

I have had no luck searching online for a solution :(

  Reply Reply Quote & Reply Quote & Reply
Dominic
VIP Member
Posts : 6
Level :
Tech Points : 2
From: United States
Posted:5/17/2012 3:28:00 AM # 2
Same problem here. I have contacted Asus about this, will let you know if they figure it out for me. Asus P8Z77-V Deluxe

  Reply Reply Quote & Reply Quote & Reply
Dominic
VIP Member
Posts : 6
Level :
Tech Points : 2
From: United States
Posted:5/20/2012 7:02:00 AM # 3
So I got mine to work again. Reset CMOS, unplug the power from your system and then push and hold clear CMOS button. After that restore your settings manually, dont restore from a profile. After that download the latest AI suite and make sure you check fanexpert2 10015 and then restart. Hope this helps

  Reply Reply Quote & Reply Quote & Reply
cliche
Posts : 1
Level :
Tech Points : 1
From: United Kingdom
Posted:5/24/2012 8:53:00 AM # 4

Quote:
Author: Dominic Posted: 5/17/2012 3:28:00 AM

Same problem here. I have contacted Asus about this, will let you know if they figure it out for me. Asus P8Z77-V Deluxe


Please let me know too - I have an Asus P8Z77-V Deluxe with the same problem Win 7 64-bit. Thanks

  Reply Reply Quote & Reply Quote & Reply
McRey
VIP Member
Posts : 6
Level :
Tech Points : 2
From: Indonesia
Posted:9/3/2012 1:08:00 PM # 5
Posted: 5/17/2012 3:28:00 AM

Same problem here. I have contacted Asus about this, will let you know if they figure it out for me. Asus P8Z77-V Deluxe Please let me know too - I have an Asus P8Z77-V Deluxe with the same problem Win 7 64-bit. Thanks


I has 2 asus mobo, p8p67 deluxe and p8z77 deluxe!! And both of them has the same problem with asus fan xpert 2!! It just work only when the first install after i reboot my pc it turn to This massage server execution failed, ProgID: AsusFanControlService.FanControlManager I already instal my win again for several time but always the same!!! Please help me

  Reply Reply Quote & Reply Quote & Reply
McRey
VIP Member
Posts : 6
Level :
Tech Points : 2
From: Indonesia
Posted:9/3/2012 5:09:00 PM # 6
I has 2 asus mobo, p8p67 deluxe and p8z77 deluxe!! And both of them has the same problem with asus fan xpert 2!! It just work only when the first install after i reboot my pc it turn to This massage server execution failed, ProgID: AsusFanControlService.FanControlManager I already instal my win again for several time but always the same!!! Please help me

  Reply Reply Quote & Reply Quote & Reply
peter1971
VIP Member
Posts : 3
Level :
Tech Points : 2
From: Slovenia
Posted:9/10/2012 3:57:00 PM # 7

Quote:
Author: Aldo Posted: 9/3/2012 5:09:00 PM

I has 2 asus mobo, p8p67 deluxe and p8z77 deluxe!! And both of them has the same problem with asus fan xpert 2!! It just work only when the first install after i reboot my pc it turn to This massage server execution failed, ProgID: AsusFanControlService.FanControlManager I already instal my win again for several time but always the same!!! Please help me


James
VIP Member
[Problem]
*Solved*Thermal Radar stopped working/Error message
Found it!

First find the AppID for the AsusFanControlService under HKEY_CLASSES_ROOT\AppID\AsusFanControlService.EXE.

In my case this is AppID={BEBCB884-9C21-4117-B30B-CED03A72B50F}

Now find the CLSID entry for "FanControlManager Class"

In my case this is HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{14083C53-B8E7-48E4-9320-811F3478C4A4}

Now in the CLSID add a new String Value (not a key) with an AppID pointing to the AsusFanControlService
AppID={BEBCB884-9C21-4117-B30B-CED03A72B50F}

After a reboot, AI Suite II/Fan Xpert started working again.

  Reply Reply Quote & Reply Quote & Reply
McRey
VIP Member
Posts : 6
Level :
Tech Points : 2
From: Indonesia
Posted:9/11/2012 7:40:00 AM # 8

Quote:
Author: peter1971 Posted: 9/10/2012 3:57:00 PM


Quote:
Author: Aldo Posted: 9/3/2012 5:09:00 PM

I has 2 asus mobo, p8p67 deluxe and p8z77 deluxe!! And both of them has the same problem with asus fan xpert 2!! It just work only when the first install after i reboot my pc it turn to This massage server execution failed, ProgID: AsusFanControlService.FanControlManager I already instal my win again for several time but always the same!!! Please help me


James
VIP Member
[Problem]
*Solved*Thermal Radar stopped working/Error message
Found it!

First find the AppID for the AsusFanControlService under HKEY_CLASSES_ROOT\AppID\AsusFanControlService.EXE.

In my case this is AppID={BEBCB884-9C21-4117-B30B-CED03A72B50F}

Now find the CLSID entry for "FanControlManager Class"

In my case this is HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{14083C53-B8E7-48E4-9320-811F3478C4A4}

Now in the CLSID add a new String Value (not a key) with an AppID pointing to the AsusFanControlService
AppID={BEBCB884-9C21-4117-B30B-CED03A72B50F}

After a reboot, AI Suite II/Fan Xpert started working again.


how to make a String Value (not a key) with an AppID pointing to the AsusFanControlService??? can u gave me the format???? i already open my reg edit but dont know how to make it!! Thanks

  Reply Reply Quote & Reply Quote & Reply
peter1971
VIP Member
Posts : 3
Level :
Tech Points : 2
From: Slovenia
Posted:9/11/2012 6:13:00 PM # 9

Find

HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{14083C53-B8E7-48E4-9320-811F3478C4A4}

with the right mouse button to open the menu
add a new String Value - AppID

On AppID with the right mouse button to open the menu and  Modify and enter in
the row below AppID     
     
{BEBCB884-9C21-4117-B30B-CED03A72B50F}

  Reply Reply Quote & Reply Quote & Reply
Mike
Posts : 2
Level :
Tech Points : 2
From: Finland
Posted:12/7/2012 11:26:00 PM # 10
Thank you Peter1971 for the registry fix! My fan control didn't work after installation but this registry fix got it working. I didn't even need to reboot, just applying the right AppID got it working.

  Reply Reply Quote & Reply Quote & Reply
1 2  Next  Last
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.