SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > P8H67-I Deluxe  
  Forum  
  Topic : [Problem]Install Windows 7 in EUFI mode New Topic
Tripkebab
VIP Member
Posts : 5
Level :
Tech Points : 1
From: United Kingdom
Posted:6/28/2011 8:52:00 AM # 1
I have purchased a P8H67-I Deluxe along with a WD Green 3tb HDD.

I'm trying to install Windows 7 in UEFI mode so I can install on a GPT partition.

No matter what I do in the firmware or the boot menu I dont get the option to boot the CD as UEFI.

Pulling my hair out here, what am I doing wrong?

  Reply Reply Quote & Reply Quote & Reply
Ghe
VIP Member
Posts : 5511
Level :
Tech Points : 3703
From: Romania
Posted:6/28/2011 3:48:00 PM # 2
Hi T, See if it does help: http://www.insanelymac.com/forum/index.php?showtopic=184349.
If you restart and enter BIOS with Windows 7 inserted in the DVD drive, do you get a UEFI icon on the DVD in the "Boot Priority" section?

  Reply Reply Quote & Reply Quote & Reply
Ghe
VIP Member
Posts : 5511
Level :
Tech Points : 3703
From: Romania
Posted:6/28/2011 5:57:00 PM # 3

Well, for me it worked (I can't test the image cause I don't have an EFI BIOS):
Download OSCDIMG 2.54 from
http://www.megaupload.com/?d=8YDVJFNO
Copy it in the unarchived Win7 folder (let's say f:)
Then, in Command prompt, go to the f: dir and type:
oscdimg -w4 -os -Win_7_x64_UEFI_ISO9660 -m -o -n -pEF -e -bf:\efi\microsoft\boot\efisys.bin f:\ f:\Win_7_x64_UEFI_ISO9660.iso

I'm not sure though what's the difference from the original Win7 files.


  Reply Reply Quote & Reply Quote & Reply
Tripkebab
VIP Member
Posts : 5
Level :
Tech Points : 1
From: United Kingdom
Posted:6/28/2011 5:12:00 PM # 4
Hi Ghe,

Thanks for the post, I had already been scouring the net before making my post and already came across the link you provided, I do not get an UEFI Icon on the DVD in the boot priority section. Neither do I get the option to boot the CD as UEFI in the advanced section boot overide or from the boot menu (F10 during setup)

I tried and failed modifying the install disk to force it to boot in EUFI mode.

I copied oscdimg to f: and extracted my Win 7 (64bit) install CD to f: folder called WIN64ISO. I then ran the following command only to recieve an error stating 'invalid peramiter -d'

oscdimg -w4 -os -lWin_7_x64_UEFI_ISO9660 -m -o -n -pEF -e -bf:\WIN64ISO\efi\microsoft\boot\efisys.bin f:\WIN64ISO f:\Win_7_x64_UEFI_ISO9660.iso

Maby im doing something wrong when running this CMD?

The other thing that the website is talking about is launching VIA efi shell, however when I try to launch EFI shell it comes back saying 'Warning: not found'.

I have tried downloading rEFIt's shell and copying rEFIt' files to memory stick, this does then give me a boot option & EUFI icon on the memory stick but launching that just makes the screen flicker black and takes me back to the bios. I'm sure im missing steps here also.

Very new to this and havent had prior experience with 3TB drives or EUFI so any help is much appreciated.

Thanks,


  Reply Reply Quote & Reply Quote & Reply
Tripkebab
VIP Member
Posts : 5
Level :
Tech Points : 1
From: United Kingdom
Posted:6/28/2011 5:13:00 PM # 5
Think it's also worth me noting I have a p8p67 Deluxe mobo also and have exactly the same issue on this.

  Reply Reply Quote & Reply Quote & Reply
Tripkebab
VIP Member
Posts : 5
Level :
Tech Points : 1
From: United Kingdom
Posted:6/28/2011 6:18:00 PM # 6
Thanks, Ill give this a go tonight using your file and cmd

  Reply Reply Quote & Reply Quote & Reply
Tripkebab
VIP Member
Posts : 5
Level :
Tech Points : 1
From: United Kingdom
Posted:6/30/2011 5:05:00 AM # 7
Just letting everyone know what happened in the end.

Finally got it working by downloading the oscdimg file you linked me and then voila my cmd worked to create the Force EUFI disk.

Seems I originally downloaded a bad/old file.

So for anyone else having similar issues if you want to install windows on a 3tb drive on this board or similar you must do the following!

Note it must be 64bit Windows 7 or Vista.

1. Ensure you have a Windows 7 install that will boot in EUFI mode.
2. Install the drive
3. Go into the bios and set sata mode to ACHI
4. From the bios boot overide the EUFI:*disknamehere*
5. When in window setup you will need to convert the drive to GPT format.

Use the following method to do this.

Press shift F10 in Windows 7 install (drive selection screen) to bring up a cmd prompt.
Type the following. (press enter after each line)

Diskpart
Select disk 0 (or whatever the name of the disk you want to convert is displayed as)
clean (this will wipe all info from the drive)
convert GPT (will convert the disk to GPT format)
create partition msr size =128 (will create a 128 mb system reserved partition)
create partition primary (create partition for your windows install)

6. Exit cmd and click the refresh button.
7. Install windows on your primary partition.

You can probably create your partitions in windows setup once you have converted to gpt rather than doing in CMD if your more comfortable doing that. I never tried it tho so cant guarantee itl do it right.

Also apoligies if I got any of the commands wrong, im not a big dos person and typed this up from memory, type help if one of them dosent work.

Thanks for the help and hope someone finds this usefull.

  Reply Reply Quote & Reply Quote & Reply
Ghe
VIP Member
Posts : 5511
Level :
Tech Points : 3703
From: Romania
Posted:6/30/2011 5:33:00 AM # 8
Useful indeed, T, thank you for posting it. All the best!

  Reply Reply Quote & Reply Quote & Reply
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.