SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > P5B  
  Forum  
  Topic : Asus P5B - 4GB ram help New Topic
shippee
VIP Member
Posts : 3
Level :
Tech Points : 1
From: United States
Posted:6/19/2007 12:09:00 AM # 11
Here is another twist.

I have 4 1GB memory SDRAM DIMMS installed in P5B motherboard.

I installed /sos switch inWindows Server 2003 Enterprise Edition boot.ini file, and it sees 4 GB RAM upon booting windows.

It shows 4 GB of RAM with PAE enabled.

But when I install Microsoft Virtual PC 2007 (free from Microsoft) or Microsft's Virtual Server the application only sees 2 GB of memory available for use.

I'm not sure it is a 3 GB vs 4  GB issue - Windows appears to only be able to use 2 GB of RAM with a P5B MB from within a Windows application.  Shucks.

  Reply Reply Quote & Reply Quote & Reply
Kabirov
VIP Member
Posts : 6
Level :
Tech Points : 0
From: Russia
Posted:6/19/2007 1:17:00 AM # 12

Quote:
Author: RipThorn Posted: 6/14/2007 11:14:00 AM

This just in. Taken from P5B manual
If you install four 1 or 2 gig memory modules, the system may only recognize less than 3GB bacause the address space is reserved for other critical functions.

In other words Asus does not guarantee that you will be able to use 4 or even 8 gig of ram.
Sounds like BS to me. I need more ram for my VMware server testing as i;m running multiple 2003 server 64-bit guests.

I have the same problem, 2Gb before + 2Gb after and BIOS recognize only 3Gb of 533 MHz RAM. But the cpu-z software (www.cpuid.com) detects all four modules of RAM!  Is here someone from tech support?
By the way, there's no 533MHz RAM in Asus RAM Qualified Vendors List at all, so I can't figure which one is approved. I had 2 Kingston and 2 Kingmax modules, both are 1024Mb PC2-4300 at 533MHz.

  Reply Reply Quote & Reply Quote & Reply
ryandinan
VIP Member
Posts : 66
Level :
Tech Points : 0
From: United States
Posted:6/20/2007 12:01:00 AM # 13
There is a Microsoft knowledgebase article about this... I remember reading it, but I can't remember what it was called.  Anyway, all win32 applications are limited to 2GB of address space, regardless of how much RAM you have installed, unless you enable a special switch.  There is a program called CFF explorer that allows you to change the header files in .exe's to enable this switch.  If you are within a 32-bit OS, you'll also need to add some lines to your boot.ini file to get it to work;  If you're in a 64-bit OS, you can stop after adding the switch in the exe.

I'm in Vista 64 with 4GB of RAM.  I was upset that Flight Sim X couldn't use more than 2GB or RAM, as it desparately needed to be able to.  After some reading around, I discovered the above trick - I added th switch, and now, FSX can use up to 3GB all for itself, leaving the other 1GB for system processes.

-Ryan


  Reply Reply Quote & Reply Quote & Reply
Core2 Duo @ 3.2GHz (8x400) Asus P5B Rev. 1.04G 4GB Corsair DDR2 800 ATI Radeon X1900XT Thermaltake 700W PSU Vista Ultimate 64-bit
Kabirov
VIP Member
Posts : 6
Level :
Tech Points : 0
From: Russia
Posted:6/20/2007 12:35:00 AM # 14

Hi everyone,

today's morning I had contacted with ASUS tech support, here's the answer:
To enable BIOS to correctly identify 4Gb's of RAM, go to the BIOS settings - Advanced - Chipset - Northbridge configuration and set Memory Remap to Enabled.

It works fine for me, now MB can see all 4Gb. OK, now I'm going to install Vista x64 and see if it can use all of them :)

  Reply Reply Quote & Reply Quote & Reply
ryandinan
VIP Member
Posts : 66
Level :
Tech Points : 0
From: United States
Posted:6/20/2007 12:44:00 AM # 15

Quote:
Author: Kabirov Posted: 6/20/2007 12:35:00 AM


Hi everyone,

today's morning I had contacted with ASUS tech support, here's the answer:
To enable BIOS to correctly identify 4Gb's of RAM, go to the BIOS settings - Advanced - Chipset - Northbridge configuration and set Memory Remap to Enabled.

It works fine for me, now MB can see all 4Gb. OK, now I'm going to install Vista x64 and see if it can use all of them :)


Kabirov -

Sorry you hear you had to resort to calling Asus tech support for this...
This solution was mentioned at least twice in this thread alone... just a few posts after the author's initial question.  Not to mention, the numerous other threads about this same thing - and the fact that it's in the FAQ for this motherboard.... ;-)

Vista-64 will love 4GB of RAM by the way... runs much nicer than only 2GB.

-Ryan


  Reply Reply Quote & Reply Quote & Reply
Core2 Duo @ 3.2GHz (8x400) Asus P5B Rev. 1.04G 4GB Corsair DDR2 800 ATI Radeon X1900XT Thermaltake 700W PSU Vista Ultimate 64-bit
Kabirov
VIP Member
Posts : 6
Level :
Tech Points : 0
From: Russia
Posted:6/20/2007 2:05:00 PM # 16

Quote:
Author: ryandinan Posted: 6/20/2007 12:44:00 AM


Quote:
Author: Kabirov Posted: 6/20/2007 12:35:00 AM


Hi everyone,

today's morning I had contacted with ASUS tech support, here's the answer:
To enable BIOS to correctly identify 4Gb's of RAM, go to the BIOS settings - Advanced - Chipset - Northbridge configuration and set Memory Remap to Enabled.

It works fine for me, now MB can see all 4Gb. OK, now I'm going to install Vista x64 and see if it can use all of them :)


Kabirov -

Sorry you hear you had to resort to calling Asus tech support for this...
This solution was mentioned at least twice in this thread alone... just a few posts after the author's initial question.  Not to mention, the numerous other threads about this same thing - and the fact that it's in the FAQ for this motherboard.... ;-)

Vista-64 will love 4GB of RAM by the way... runs much nicer than only 2GB.

-Ryan



Well, it was 1 time, but I haven't got an idea where to find this feature. As I can see, other people also can't. I searched FAQ before replying here in first time, and there is no solution - may be if it's hidden deep somewhere in the tons of posts about other MB's . I supposed, Motherboards-P5B should get all answers, and it doesn't. Or you can show me the url?  Anyway, this must be in FAQ with biggest header font.

  Reply Reply Quote & Reply Quote & Reply
lee
Member
Posts : 6
Level :
Tech Points : 2
From: Canada
Posted:9/3/2009 5:27:00 PM # 17
My system: P5B-VM with BIOS 1004

My OS: Windows 7 Ultimate 64-bit

My problem: Memory Remapping doesn't work. Without it, bios boots with 2816MB; with remapping enabled, windows runs insanely slow. If I try to reinstall windows, I even get the Blue Screen of Death (BSOD) saying "DRIVER_IRQL_NOT_LESS_OR_EQUAL"

Any ideas?

  Reply Reply Quote & Reply Quote & Reply

Posts :
Level :
Tech Points : 0
From:
Posted:11/10/2009 7:04:00 PM # 18
I've seen the same problems days agoo but maybe I have other info:

I have a P5B with latest Bios (2104 - 27-May-2009).
I'm running Windows 7 Pro 64 Bit.

I have 4 GB (2 x 2GB DDR2 modules) of ram but bios says I have only 2.4 GB available.
Windows correctly says I have 4GB but only 2.4 are available.

2 days ago I tried to add 2 more 512 MB DDR2 Ram modules ( 1GB more, total 5GB) and:
Bios syas I have 3.4 GB
Windows Says I have 5GB but only 3.4 free.

Yesterday I've removed the two 512MB modules and replaced them with 2x1GB modules (total ram 6 GB) and now:
Bios syas I have 4.4 GB
Windows Says I have 6GB but only 4.4 free.

Looks like that wathever I do 1.6 GB of ram are disappeared...
Anyone have an Idea of the reason of this behaviour?

(p.s.)I've not tried to enable the Memory remapping option into the bios. I will try this later.

  Reply Reply Quote & Reply Quote & Reply
doyling
VIP Member
Posts : 28
Level :
Tech Points : 37
From: United States
Posted:11/21/2009 11:58:00 PM # 19
You guys are driving me nuts. The bottom line. If you have 4 or more gig of ram, you need to turn on memory remap. AND you need to run a 64bit OS. XP 64, Vista 64, Win7 64, Linux 64. You must run 64bit OS if you have 4 gig or more of memory. It is that simple. Windows will support 4 gig in a 32bit OS to a point, it will allocate some of the memory to other functions, and subtract that amount from the amount of memory shown.

So, 4 gig or more, memory remap on, use 64 bit OS
3.99 gig or less, no memory remap and 32 bit OS

GRRRRRR
(puts away the podium and walks away quietly)

  Reply Reply Quote & Reply Quote & Reply
BarryC
Member
Posts : 1
Level :
Tech Points : 0
From: Netherlands
Posted:1/5/2010 3:48:00 PM # 20
I think it's a little simple to simply say that you need a 64-bit OS to address 4GB or more of ram. I had an Intel Core 2 duo 6600 system with 2GB (2 x 1GB) Corsair XMS2 memory on an Asus P5B motherboard with Vista 32-bit installed. Just lately I installed Windows 7 64 Enterprise on my computer and decided to upgrade my PC to 4GB ram. I thought it would be as simple as plugging the 2 1GB modules in but I was very sadly mistaken. But thank God for the internet, I got it working after trying a number of tips I found.

When I first installed the two 1GB modules and rebooted my computer the computer would hang by the reboot, while initializing the memory. I removed the 2GB and it worked again. I tried 3GB and that worked too. I also tried plugging 2 and 3GB into a variation of the 4 memory slots I had available (thinking that my motherboard may be the problem), but everything worked fine.

Then I came across a post explaining the BIOS "Memory remapping" option (Advanced -> Northbridge Settings). It was disabled on my PC. I enabled it, shutdown the PC, installed the 4GB and rebooted the PC. I saw "4096" in the boot information on the screen, YES!!! Happy, happy, happy.

Until my PC kept rebooting itself, until I got a screen saying that "Windows failed to start.". I was presented with two options, one to recover and one to start Windows normally. The recover option simply locked up the computer while the "start normally" option brought you back to where you were after trying to reboot the computer a number of times.

Then I found a post where someone got there PC working again by reducing the clock speed of their memory. I had 800Mhz memory, my BIOS (under Advanced -> Northbridge Settings -> Jumper Settings) was set to AUTO. I changed it to 533Mhz and rebooted. YES!!! I have my 4GB of memory and my operating system starts. Up to now I haven't experienced any problems (knock on wood).

Just for the heck of it I tried setting the clock speed of the memory to 667Mhz, but after rebooting, the operating system wouldn't start, I got the same problem as described before. I set it back to 533Mhz and everything is working like a charm. Luckily I'm not an over-clocker, but if anything, I'm sure my computer starts up much faster than before. Maybe it's psychological, I don't know, but I'm content.

I also heard about a software limitation on the amount of memory to be used by the operating system. If you execute "msconfig" from the Start menu, go to the "Boot" tab and click "Advanced", there is a checkbox to limit the amount of memory used. On my computer it was not checked so it wasn't a problem for me, but if it is checked and the amount of memory is less than what your installing, then simply uncheck it.

  Reply Reply Quote & Reply Quote & Reply
First  Prev  1 2
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: Ulrich New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.