SEARCH
ASUS Member ID
Password
Forgot password?
Join member

ASUS Support Home Location : Forum > Motherboard > M4A89GTD PRO/USB3  
  Forum  
  Topic : [Problem]BIOS EHCI Hand-off should be disabled? New Topic
OppfinnarJocke
VIP Member
Posts : 26
Level :
Tech Points : 42
From: Sweden
Posted:12/27/2010 7:44:00 AM # 1
My mobo BIOS has the option for EHCI handoff. The manual says that this "enables support for operating systems without an EHCI hand-off feature". From what I understand, Win XPsp2 and onwards all have the EHCI hand-off feature, right?

So shouldn't this option be disabled in the BIOS?

Logitech think so, among others: "EHCI Handoff is [ENABLED] as a default in most motherboards, and should be [DISABLED] if you are using Windows XP SP2 or greater."

The reason I am asking is because 4 non-enhanced USB controllers show up in my device manager, though the mobo is supposed to only have USB 2 (and 3) ports. If I disable EHCI hand-off (but leave Legacy USB Support at Auto) in the BIOS, three of the non-enhanced USB controllers report "cannot start. (Code 10)". I'm at odds...

Anyone have any ideas?

  Reply Reply Quote & Reply Quote & Reply
M4A89GTD Pro/USB3, AMD Phenom II x6 T1055 2.8GHz, Corsair XMS3 4096MB DDR3 PC3-12800 1600MHz, Samsung Spinpoint F3 500 GB, W7x64pro
punk_emo_dude
Member
Posts : 2
Level :
Tech Points : 2
From: United States
Posted:1/4/2011 5:21:00 PM # 2
I wud suggest leaving the option set 2 'ENABLED'. I had it set 2 'DISABLED'and I got 3 yellow !s(bangs)in Device Manager under the 'USB CONTROLLERS' section both on Vista 64 bit and XP 32 bit no matter what other settings I tryed changing. Once I set 'BIOS EHCI HANDOFF' 2 'ENABLED' the yellow !s in Device Manager are gone in Vista and XP. I'm thinking from what the help says in BIOS about this item that setting it 2 'ENABLED' tells BIOS 2 handoff control of EHCI to the OS when Windows starts 2 load. BTW my setup is M4A89GTD Pro/USB3, AMD Phenom II x6 1090T@3.2 Ghz and v1606 BIOS.

  Reply Reply Quote & Reply Quote & Reply
OppfinnarJocke
VIP Member
Posts : 26
Level :
Tech Points : 42
From: Sweden
Posted:1/7/2011 2:45:00 AM # 3
I also got the three yellow exclamation marks when I turned it off, until I also disabled Legacy USB Support. W7 isn't an OS that needs legacy support, and it can manage its own EHCI Hand-off, so I think this is the way it should be. That is, with both Legacy Support and EHCI Hand-off disabled. Works fine for me...

  Reply Reply Quote & Reply Quote & Reply
M4A89GTD Pro/USB3, AMD Phenom II x6 T1055 2.8GHz, Corsair XMS3 4096MB DDR3 PC3-12800 1600MHz, Samsung Spinpoint F3 500 GB, W7x64pro
1
Previous Topic:: Next Topic
Feedback for our Website ModeratorModerator: New Topic Related FAQ Related FAQ Forum Home Forum Home
Forum Model :
Legal Information | Privacy Policy | Sitemap | Contact Us | ASUS Global
  ©ASUSTeK Computer Inc. All rights reserved.